Tips on using this forum..

(1) Explain your problem, don't simply post "This isn't working". What were you doing when you faced the problem? What have you tried to resolve - did you look for a solution using "Search" ? Has it happened just once or several times?

(2) It's also good to get feedback when a solution is found, return to the original post to explain how it was resolved so that more people can also use the results.

Formula editor shows error with correct formula

7 replies [Last post]
Jhorbam Baena Orozco
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 14 Sep 2009
Posts: 74
Groups: None
Formula editor shows error with correct formula Greetings. I am writing for the following reason, my copy of MS Project fails when trying to add a formula in a numeric custom field specifically the "Number 2". I tried several times without achieving anything, even modifying the original formula. These are the formulas IIf ([Job] <> 0 | Format ([Actual Job] / [Job] | "0.00%") | "0.00%")IIf ([Work]> 0 | ([Actual Work] / [Work]) * 100 | 0) These are the names of the fields in Spanish, what they do is calculate the executed work with decimals, since project only shows integers. The error MS Project indicates is always in the first PIPE from left to right. I opened a previous file that had one of these formulas included and it works, but when opening the formula and clicking OK, the same error appears ... although the formula works in the file until the editor is opened. Captures of the error are attached ... I appreciate someone tell me that it may be happening, or if it is an additional configuration of the S.O. 
7494
error_01.png
 
7495
error_02.png
 Thank you

Replies

Rafael Davila
User offline. Last seen 1 hour 44 min ago. Offline
Joined: 1 Mar 2004
Posts: 4915

https://elringdepm.wordpress.com/formulas/

I see Spanish field names and comma separator, maybe this is the Key.

Jhorbam Baena Orozco
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 14 Sep 2009
Posts: 74
Groups: None

Sorry din't work

Jhorbam Baena Orozco
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 14 Sep 2009
Posts: 74
Groups: None

Thank you for your answer, I will read it and try ... then I will comment on the results

Rafael Davila
User offline. Last seen 1 hour 44 min ago. Offline
Joined: 1 Mar 2004
Posts: 4915

I do no longer use MS Project but in order to avoid software issues with language I always use English settings. I always use US English keyboard for similar reason. Maybe your regional settings are the source of these issues.

MSP: Install and Configure the Microsoft Project Interface

Configure Windows Regional Settings

In some cases, if you save a project with non-matching OS and application language settings, data loss can occur.

Jhorbam Baena Orozco
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 14 Sep 2009
Posts: 74
Groups: None
Hi Rafael, I did it but still the error keeps appearing. As I indicated, I have other schedules with fields that I have formulated myself but when opening them in this version that they installed me (MS Project Professional 2016 in Windows 10 Home Single Language), now that the laptop is formatted it generates that error and does not let me create or edit formulas. In these schedules they work well if I don't edit the formulas, that is, they are well generated; But if I enter the editor and click on the edit text box, and then click OK without modifying anything, puff the error is generated in a functional formula. In my Regional settings the Pipe is my list separator, therefore I don't see the error.
Jhorbam Baena Orozco
User offline. Last seen 4 weeks 2 days ago. Offline
Joined: 14 Sep 2009
Posts: 74
Groups: None
Sorry, the comment was duplicated and I had to edit it
Rafael Davila
User offline. Last seen 1 hour 44 min ago. Offline
Joined: 1 Mar 2004
Posts: 4915

Try substituting “|” with a comma “,”.