Forum Sponsor:

An innovation in P6 Professional training from RPCuk in partnership with Oracle. All the topics that matter to you in workshops customised to your role and industry.  Now get superior training value when you book our Blended Learning Bundle. Learn more here.

Viewer for .xer, xml and xls schedule files Schedule Reader™Free Trial

Tips on using this forum..

(1) Explain your problem, don't simply post "This isn't working". What were you doing when you faced the problem? What have you tried to resolve - did you look for a solution using "Search" ? Has it happened just once or several times?

(2) It's also good to get feedback when a solution is found, return to the original post to explain how it was resolved so that more people can also use the results.

Fixed duration / unit activities– Duration Changes

3 replies [Last post]
Abilash Palakkada...
User offline. Last seen 3 years 30 weeks ago. Offline
Joined: 25 Aug 2012
Posts: 47

Hi,

Today i have faced a strange problem with my P6, that the duration of my activities became zero, when i added resource and provided budgeted hours. Activity was fixed duration / units

Can someone help me to sort it out?

Regards,

Abilash 

Replies

Zoltan Palffy
User offline. Last seen 2 days 9 hours ago. Offline
Joined: 13 Jul 2009
Posts: 2381
Groups: None

ok then here is why this is happening 

Does the resource have 0 set for Default Units per Time ?

AND

Does the setting in the Projects View look under the Resource Tab is Drive activity dates by default selected ? 

if so then this is the culprit

to fix this 

Go to the Projects directory check the Resource Tab and uncheck Drive activity dates by default

and 

go to the resource directory and select your resource and set the Default Units per Time in the Resource Dictionary under the Details Tab to something other than 0.

because anything divided by zero is  ? 0

Abilash Palakkada...
User offline. Last seen 3 years 30 weeks ago. Offline
Joined: 25 Aug 2012
Posts: 47

Zoltan,

Thanks for your reply, what you said is absolutely right that will work.

But my problem is that i have to use fixed duration / units (not fixed duration / units per time).

I have fixed the problem by re importing the OD. however for me it seems like a bug... but not sure. earlier this (OD) wasn't getting changed when i add resoruces with this type of activities.

If anyone else got different opionion please share.

Zoltan Palffy
User offline. Last seen 2 days 9 hours ago. Offline
Joined: 13 Jul 2009
Posts: 2381
Groups: None

filter for all activities 

add a column for duration type 

change the first on to fixed duration/Units per time

fill down for all of the duration types

go to projects directory 

make sure that your project is open and highlighted 

go to the default tab

under duaraiton type select 

fixed duration/Units per time

 

also check your activity type and make sure that it is task dependent NOT resource dependent