Tips on using this forum..

(1) Explain your problem, don't simply post "This isn't working". What were you doing when you faced the problem? What have you tried to resolve - did you look for a solution using "Search" ? Has it happened just once or several times?

(2) It's also good to get feedback when a solution is found, return to the original post to explain how it was resolved so that more people can also use the results.

Formatting of bars over non-working time

4 replies [Last post]
Laurie Willis
User offline. Last seen 8 years 9 weeks ago. Offline
Joined: 17 Oct 2006
Posts: 21
Groups: None
Hi

I have a project which has 2 calendars, 1 for a 5 day work week and 1 for a 7 day work week. By default, the tasks work to the 5 day work week one, but a couple of tasks have the 7 day work week calendar applied.

In Format, Bar Chart I have formatted the chart so the non-working time, the weekend, is shown in green on the chart and bars, so when going over the non-working time, the bar goes ’behind’ the weekend. However, this is confusing for tasks which have the 7 day calendar applied to them, as it appears they are not being worked on over the weekend. Using the Non-working display on tasks setting, the bars using the 7 day calendar go ’over’ the non-working display to illustrate weekend working. However, the tasks using the 5 day calendar now also go ’over’ the non-working display but now have a kink in them, which is better but not ideal.

Is there anyway to set the display for tasks so, depending on which calendar they use, they either go ’over’ or ’behind’ the non-working display?

Many thanks

Replies

Mike Testro
User offline. Last seen 3 days 11 hours ago. Offline
Joined: 14 Dec 2005
Posts: 4403
Hi All

This is a problem with power project - you can only set non work folding against 1 calendar.

If I have multiple calendars I usually set the folding option to -None-.

By the way any curing time should be set on a 24hr 7day week calendar not just a 7day working week. Set the duration column to ed.

Best regards

Mike Testro
Ozkan Turgutlu
User offline. Last seen 8 years 25 weeks ago. Offline
Joined: 1 Oct 2008
Posts: 4
you can also right click on the Format Bar Chart and choose the calendar background for multiple calendars (i.e. 7 days for concrete curing and 5 day working for normal activities)
Laurie Willis
User offline. Last seen 8 years 9 weeks ago. Offline
Joined: 17 Oct 2006
Posts: 21
Groups: None
Thanks fot your help Gijs.

You were right, the problem was with the working pattern. There was a wrong work pattern assigned to the calendar. As soon as I set the right one, the formatting of the bars updated to what I wanted.

Thanks again!
Gijs Alferink
User offline. Last seen 8 years 50 weeks ago. Offline
Joined: 9 May 2008
Posts: 3
Groups: None
Hi Laurie,

I don’t know if I understoof you correct.
But if you set the workpattern in your 7 days calendar there is no weekend exception so to my knowledge there wil be no weekend appearance on your barchart.
If you apply te 7 day calendar to the task.
I tried this and the 5 day calender tasks show the weekend and the 7 day calender shows no weekend.

I hope I understood you correct and have been of any help.