Tips on using this forum..

(1) Explain your problem, don't simply post "This isn't working". What were you doing when you faced the problem? What have you tried to resolve - did you look for a solution using "Search" ? Has it happened just once or several times?

(2) It's also good to get feedback when a solution is found, return to the original post to explain how it was resolved so that more people can also use the results.

XER WBS import errors

1 reply [Last post]
Andrew Watts
User offline. Last seen 4 years 13 weeks ago. Offline
Joined: 17 Jun 2015
Posts: 3
Groups: None

Has anyone encountered errors when importing a WBS IDs into Primaverea Risk Analysis (PRA). What should read
C512-R45/P2.0.010-001.2 (P6)
is reading
C512-R45/P2.0.010-001.0280 (PRA)

It is as if PRA is ignoring the data in the XER file and just auto-incrementing the last 4 numbers as "0280" does not exist in the XER file - I have checked in Notepad.  The correct data is also available in the XER it is just that PRA is not using it. 

Levels 1 and 2 import correctly - it is 3 onwards that it just whimsically assigns WBS IDs to. Any ideas?
I have tried getting the planner to export v6 and v7 XERs. There are no user fields with the correct ID in either.

All the task IDs import correctly.

Replies

Dennis Hanks
User offline. Last seen 3 years 23 weeks ago. Offline
Joined: 17 Apr 2007
Posts: 310

Andrew; Yes. I create a UDF called, appropriately enough, PRA_WBS and sort on that. There may be better ways, but that's what I use. Good luck. I use it, even when I use direct import/link. PRA does not look at WBS coding the way I do. Not sure we have the same situation, but a UDF may solve your problem.