Guild of Project Controls: Compendium | Roles | Assessment | Certifications | Membership

Tips on using this forum..

(1) Explain your problem, don't simply post "This isn't working". What were you doing when you faced the problem? What have you tried to resolve - did you look for a solution using "Search" ? Has it happened just once or several times?

(2) It's also good to get feedback when a solution is found, return to the original post to explain how it was resolved so that more people can also use the results.

Mouse Scroll

6 replies [Last post]
Joe Richard
User offline. Last seen 13 years 30 weeks ago. Offline
Joined: 9 Nov 2006
Posts: 5
What do I have to do In P3 3.1 to make my mouse scroll work? I know it can be do because on one of the computers in my office the scroll works.

Replies

Peter Ayre
User offline. Last seen 8 weeks 4 days ago. Offline
Joined: 18 Jun 2003
Posts: 26
Groups: None
Azeem Abdul,

It is the only way I know.

Do you have a problem downloading from either site?

The problem seems to have been caused by newer versions of Intellipoint removing functionality (perhaps associated with the P3.1 16 BIT architecture?). I’ve also read somewhere that either service pack 1 or 2 for windows XP automatically installs drivers for intellipoint 5.x, which makes sense to me and how I initially lost the ability to scroll. So there may be some other ways around the problem, but I certainly haven’t tried them.

Azeem Abdul
User offline. Last seen 8 years 30 weeks ago. Offline
Joined: 13 Nov 2008
Posts: 19
HI peter ayre,
Without this downloading we cant able to srcoll the mouse...?
Peter Ayre
User offline. Last seen 8 weeks 4 days ago. Offline
Joined: 18 Jun 2003
Posts: 26
Groups: None
OK, sorry for anyone I led astray with the Wheeler software, I truely believed it had solved my problems, and it did for Suretrak, but not for P3.
What I’ve now found does work is Intellipoint 4.1 here’s what I did

Download the old Intellipoint software - IP4_12EngALLMsi.exe from the Microsoft site
http://www.microsoft.com/downloads/details.aspx?FamilyID=4348502a-61be-4...

Follow instructions here
http://articles.techrepublic.com.com/5100-10878_11-5030766.html
to remove old mouse drivers. In my case I have an Alps touch pad driver that I did not remove during this process. Make sure to disconnect your mouse first otherwise xp will just keep reinstalling drivers. I’ve also read about others having real problems trying to uninstall Intellipoint 5.xx, sorry I can’t help if you have these problems as mine seemed to work fine.

run the Intellipoint 4.1 software. I followed all the setup prompts including re-boot and set up a "Wheel Mouse Optical", THEN I reconnected my mouse, which was a Logitech simple two button optical with scroll wheel. The mouse started working, BUT still no scrolling in P3, so go to bed cursing, still not working next day at work, but notice an error saying setup.exe terminated by IT Policy, get home bypass IT Policy so I can boot up laptop without it being connected to company LAN and low and behold it’s scrolling in P3. So it seems it needs a second reboot (without restrictions) to finish installation.

It seems to only work with simple two button optical mice with scroll wheel, even an old Dell one I have, but not with new mice with extra buttons eg. a newer Dell one I have with up/down arrow buttons on the side does not work.

good luck
Peter Ayre
User offline. Last seen 8 weeks 4 days ago. Offline
Joined: 18 Jun 2003
Posts: 26
Groups: None
It all has to do with the newer versions of intellipoint that come with latest versions and service packs for XP etc that do not support some existing programs such as P3 or Suretrak.

Don’t waste your time trying to configure mouse drivers.

There is a solution, use free Wheeler software http://www.eluent.com/wheeler.htm
read the instructions that come with this software for Adding a new Window Class.
You will new to add a new "scoped" window class and select the "translate wheel to scrollbar message".

read the instructions and it will make sense.

Peter
Alex Wong
User offline. Last seen 8 years 2 weeks ago. Offline
Joined: 12 Feb 2003
Posts: 874
Groups: TILOS
there is a software call
"Freewheel" (Cannot remember the exact name sorry)
that you can download for free

I think you can search it in the Primavera Knowledge base and they provide the solution for this and also in this forum there is a old topic on this one

Good Luck

Alex
MK TSE
User offline. Last seen 44 weeks 6 days ago. Offline
Joined: 27 Feb 2002
Posts: 552
Groups: None
It depends on the settings in window and version of mouse driver.