Tips on using this forum..

(1) Explain your problem, don't simply post "This isn't working". What were you doing when you faced the problem? What have you tried to resolve - did you look for a solution using "Search" ? Has it happened just once or several times?

(2) It's also good to get feedback when a solution is found, return to the original post to explain how it was resolved so that more people can also use the results.

Monthly Duration Not Giving Fixed Monthly Hours

5 replies [Last post]
troon sigma
User offline. Last seen 1 week 4 days ago. Offline
Joined: 15 Apr 2020
Posts: 13
Groups: None

Hi guys,

I have the following settings:

1. In Calendar, monthly hours are 150

2. Duration Format (in User Preferences) is set to Months.

Now, when i enter activity duration to 1 month,  I see 150 monthly hours, which is fine.  But when i put 2 months duration, i get 166 hours in first month and 134 and second month. (although the total is 300, which is fine)

Similarly, if i put 3 month or 4 month duration, i am not getting fixed 150 hours for each month.   

Fixed hours should not be expected for each month? And how can i fix the monthly hours?

 

Thanks

Replies

Zoltan Palffy
User offline. Last seen 2 days 21 hours ago. Offline
Joined: 13 Jul 2009
Posts: 2773
Groups: None

glad i could help 

troon sigma
User offline. Last seen 1 week 4 days ago. Offline
Joined: 15 Apr 2020
Posts: 13
Groups: None

Thanks Zoltan

Zoltan Palffy
User offline. Last seen 2 days 21 hours ago. Offline
Joined: 13 Jul 2009
Posts: 2773
Groups: None

how can you put in 1 day when the planning unit is months ?

you are going to get different numbers because not ALL months have the same number of working days.

the only work around is to set the hours in the calendar  

so when a month has 29 days you make sure that the total hours in that calendar is 150

now when you have a month where there are 30 or 31 days you will have to make 1 or 2 days as non working days so you still get 150 hours per month

troon sigma
User offline. Last seen 1 week 4 days ago. Offline
Joined: 15 Apr 2020
Posts: 13
Groups: None

Hi Zoltan,

Thank you for your reply.

I did exactly how you said. But i am getting 150 hours for 1 month duration and 2 month duration. As i increase to 3 months or more, then i get different values for each month.

 

Just, I put 1 in Day and Week as it does not let it be 0 or blank

 

Any further help please?

Zoltan Palffy
User offline. Last seen 2 days 21 hours ago. Offline
Joined: 13 Jul 2009
Posts: 2773
Groups: None

Admin

Admin preferences

Time Period Tab

Hours/day = 0

hours/week = 0

Hours/Month =150

Hours per year = 1800

you will have to either uncheck here where it says assign calendar to specify the number of work hours for each time period

or make sure that the hours in each month in your calendar is 150