Tips on using this forum..

(1) Explain your problem, don't simply post "This isn't working". What were you doing when you faced the problem? What have you tried to resolve - did you look for a solution using "Search" ? Has it happened just once or several times?

(2) It's also good to get feedback when a solution is found, return to the original post to explain how it was resolved so that more people can also use the results.

Imported XER showing as 4 separate items in the EPS

6 replies [Last post]
Thomas Nicholson
User offline. Last seen 5 weeks 2 days ago. Offline
Joined: 4 Oct 2006
Posts: 73
Groups: None

Afternoon all,

I've been sent an XER file of a single plan, yet once the import is complete it's showing as 4 separate items in the enterprise screen.  Open one and they all open, try to delete one and all go.  It's behaving as one but appearing as 4. 

Anyone got any ideas? Nearly 20 years of Primavera and I've not seen this before. 

Thanks, 

Thom

Replies

Steven Auld
User offline. Last seen 19 hours 35 min ago. Offline
Joined: 13 Sep 2017
Posts: 109

Thomas,

Sounds like the WBS on the import file is corrupt & instead of being seen as a child of the Project they are not getting the reference to the correct project ID & then showing as additional projects.

I have seen this a number of times, but usually when manually editing the WBS to add additional values.

When you delete the project that they are supposed to be under then the additional records should also be deleted.

This can also be caused by having certain punctuation in the WBS codes that have been added ouside of Primavera.

If you are able to share the file then I could have a look to check for these errors if you want.

EDIT - Apologies - never noticed that you had fixed it.

Regards,

Steven

Thomas Nicholson
User offline. Last seen 5 weeks 2 days ago. Offline
Joined: 4 Oct 2006
Posts: 73
Groups: None
Hi all, We think the problem has happened due to a Microsoft project import and it not having a parent to the included WBS. Solved it by creating a new empty plan and copying these into it. Thanks for the suggestions Thom
Santosh Bhat
User offline. Last seen 1 hour 16 min ago. Offline
Joined: 15 Apr 2005
Posts: 271

If the single plan you are looking at contains relationships to other projects, then a record of those proejcts will also exist in the XER and may get created when you import that XER. It may also be due to corruption of the data for the project, creating orphaned records that are also transferred in the XER file.

Mohammed Ali
User offline. Last seen 4 weeks 4 hours ago. Offline
Joined: 16 Mar 2018
Posts: 42
Groups: None

I think this problem because of the project WBS.

You have 4 Project Node in the WBS table under the same Project ID.

You may also have no parent for these 4 WBS Elements.

Be sure you have only one Y under the project node in the WBS Table.

Be sure that all WBS elements have a parent except the project itself.

Zoltan Palffy
User is online Online
Joined: 13 Jul 2009
Posts: 2743
Groups: None

only suggestion would be to open with the parser and recreat it 

Patrick Mullen
User offline. Last seen 2 weeks 18 hours ago. Offline
Joined: 15 May 2020
Posts: 19
Groups: None

Hey Tom,

I wouldn't mind taking a look if you want to send it to me. The only thing that I can think of is that they exported all 4 files at once, and you have them all open at the same time upon import. But if you want to send me the file, I can take a look.

pat@jobsessions.com

Pat