Forum Sponsor:

Portfolio Planner is software which improves portfolio, project and resource management.

Tips on using this forum..

(1) Explain your problem, don't simply post "This isn't working". What were you doing when you faced the problem? What have you tried to resolve - did you look for a solution using "Search" ? Has it happened just once or several times?

(2) It's also good to get feedback when a solution is found, return to the original post to explain how it was resolved so that more people can also use the results.

WBS Name Maximum Characters

3 replies [Last post]
Jason LI
User offline. Last seen 1 week 3 days ago. Offline
Joined: 1 Jan 2008
Posts: 37

Hi All,

When try to import a P6 XML file, show up an error window saying "Valvue too large for cloumn WBS_Name (actuall:116, maximum :100)", Any advice on how to solve it or where can adjust my WBS name Maximum Characters.

 

thanks and regards

Replies

Steven Auld
User offline. Last seen 47 min 30 sec ago. Offline
Joined: 13 Sep 2017
Posts: 109

Jason,

The 100 character limit is an absolute maximum if you are using SQL Server (or I presume Oracle Database).

It can however be exceeded when using SQLite as the database due to the difference in how this operates compared to the other 2 Database types, but I don't think that this would have been done inside the Primavera interface.

The Primavera software should not allow you to exceed the 100 character limit for compatibility, however if the file is edited outside of Primavera then it can be exceeded when it shouldn't have.

I have modified an XER file & imported into Primavera OK when using a SQLite database. Exporting from this database into an SQL Server database then failed (XER Import not XML).

This setting cannot be altered within Primavera & is hard coded into the Database structure. It could theoretically be changed at the database level, but would not recommend going down this route.

You would need to adjust the WBS Name to 100 characters or less to allow the import.

Regards,

Steven

Zoltan Palffy
User offline. Last seen 1 day 1 hour ago. Offline
Joined: 13 Jul 2009
Posts: 2716
Groups: None

all setting for lenghts are in the Admin Preferences setting.

one solution is to shorten the name 

where did the xlm come from ?

what program created it 

are you sure its not the wbs tree limit ?

Mohammed Ali
User offline. Last seen 2 days 27 min ago. Offline
Joined: 16 Mar 2018
Posts: 38
Groups: None

This is the answer from the SQL Server.

7460
wbs_name.png